Linux Mint maandnieuws mei 2020

Vertaling van maandelijks nieuws – 1 juni 2020 door Clem

Voordat we met het maandelijkse nieuws beginnen, wil ik je bedanken voor je donaties en de steun die je ons geeft. Ik wil ook onze partners en sponsors bedanken en iedereen die een bijdrage levert aan Linux Mint.

Kleuren
Vorige maand hebben we een voorbeeld gegeven van enkele van de nieuwe kleuren in het Mint-Y-thema. We dachten dat deze populair zouden zijn, maar de feedback was niet zo positief als we hadden verwacht. We kregen gemengde reacties en hoewel sommige mensen ervan leken te genieten, merkten we ook dat zoveel mensen dat niet deden, niet. Ik ben blij dat we het hebben geprobeerd, en ik ben blij dat dit vóór BETA is gebeurd. We gaan conservatief te werk en stemmen deze kleuren tijdens de BETA-fase met u af. Kortom, we zullen het aantal wijzigingen voor de meeste kleuren vóór BETA terugdraaien of verminderen, en we zullen een meta-probleem op Github opzetten met één probleem per kleur zodat je kunt deelnemen aan het proces en feedback kunt geven op de screenshots en pakketten die we publiceren.

Snap
We hebben ook uw vragen over het onderwerp snapd gehoord. Dit is een onderwerp dat belangrijk voor ons is en we hebben ons standpunt vorig jaar al uitgelegd:

[…] als u APT-updates installeert, wordt Snap een vereiste voor u om Chromium te blijven gebruiken en installeert het zichzelf achter uw rug. Dit doorbreekt een van de grootste zorgen die veel mensen hadden toen Snap werd aangekondigd en een belofte van de ontwikkelaars dat het APT nooit zou vervangen.

Een zelfinstallerende Snap Store die een deel van onze APT-pakketbasis overschrijft, is een volledig NEE NEE. Het is iets dat we moeten stoppen en het kan het einde betekenen van Chromium-updates en toegang tot de snap store in Linux Mint.[…]

Een jaar later, in de Ubuntu 20.04-pakketbasis, is het Chromium-pakket inderdaad leeg en fungeert het, zonder uw toestemming, als een achterdeur door uw computer aan te sluiten op de Ubuntu Store. Toepassingen in deze winkel kunnen niet worden gepatcht (aangepast) of vastgezet. Je kunt ze niet controleren, vasthouden, wijzigen of zelfs wijzen naar een andere winkel. Je hebt hiermee net zoveel macht of mogelijkheden alsof je gepatenteerde software gebruikt, dus geen. Dit is in feite vergelijkbaar met een commerciële, gepatenteerde oplossing, maar met twee grote verschillen: het draait als root en installeert zichzelf zonder het u te vragen.

Ten eerste ben ik blij om te bevestigen dat Linux Mint 20, net als eerdere Mint-releases, niet wordt geleverd met geïnstalleerde snaps of snapd. Ten tweede, om deze situatie aan te pakken, doen we precies wat we zeiden dat we zouden doen:
* In Linux Mint 20 is Chromium geen leeg pakket dat achter je rug kan worden geïnstalleerd. Het zal een leeg pakket zijn dat u vertelt waarom het leeg is en u vertelt waar u moet zoeken om Chromium zelf te krijgen.
* In Linux Mint 20 verbiedt APT dat snapd wordt geïnstalleerd.

U kunt het nog steeds zelf installeren en we zullen dit documenteren in de release-opmerkingen, maar APT staat standaard niet toe dat repository-pakketten dit namens u doen.

NVIDIA
Linux Mint 20 zal verbeterde ondersteuning bieden voor NVIDIA Optimus.

In Mint 20 toont de NVIDIA prime-applet nu uw GPU-renderer en u kunt rechtstreeks vanuit het menu selecteren naar welke kaart u wilt overschakelen.
Het NVIDIA “On-Demand” (Op aanvraag) profiel wordt nu ook volledig ondersteund zowel in MATE (by mintmenu) als in Cinnamon (door de Cinnamon menu applet). Wanneer u in die modus werkt, is het uw Intel-kaart die de sessie weergeeft en er is een menuoptie beschikbaar waarmee u een bepaalde toepassing naar uw NVIDIA-kaart kunt overzetten.

Selecteer een applicatie in het menu, klik met de rechtermuisknop en selecteer “Uitvoeren met NVIDIA GPU”. Het is zo simpel.
Vanaf de opdrachtregel zijn twee nieuwe opdrachten beschikbaar om te worden overgezet naar GLX of naar Vulkan:
* nvidia-optimus-offload-glx
* nvidia-optimus-offload-vulkan

Om de compatibiliteit te vergroten en het gemakkelijker te maken om Linux Mint 20 in de live-modus op te starten zonder NVIDIA-stuurprogramma’s, is “nomodeset” toegevoegd aan de “Compatibility Mode”.

Ondersteuning voor meerdere monitoren
Op sommige computers zijn hot-plugging-monitoren (aansluiten als het systeem al draaid) al jaren een probleem in Cinnamon. Afhankelijk van uw GPU en grafische stuurprogramma’s kan dit zwart knipperende texturen rond vensters en op de achtergrond van de nieuw toegevoegde monitor creëren. Vorige maand vond James Ross (@itzexor in het ontwikkelingsteam van Mint) hiervoor een oplossing. Hot-pluggin-monitoren in de komende Cinnamon 4.6 zijn nu zijdezacht. We zullen deze oplossing en een paar andere terugzetten naar Cinnamon 4.4 na de Mint 20 BETA.

In het inlogscherm (Slick Greeter) is een nieuwe optie toegevoegd waarmee je de achtergrond over meerdere monitoren kunt uitrekken.

Systeemvak
In Cinnamon’s toetsenbord-applet kun je de middelste klikknop gebruiken om door toetsenbordindelingen te bladeren.

In alle drie DE’s (Distributie Edities) (Cinnamon, MATE en Xfce) waren veel van de systeempictogrammen geharmoniseerd, met symbolische pictogrammen en HiDPI-ondersteuning.
Blueberry, mintupdate, mintreport, nm-applet, mate-power-manager, mate-media, redshift, rhythmbox gebruiken allemaal XAppStatusIcon en geven het systeemvak een consistent uiterlijk in Mint 20.

XAppStatusIcon heeft de mogelijkheid gekregen om muiswiel-scrollende gebeurtenissen af ​​te handelen en een nieuwe functie die lijkt op gtk_menu_popup (), wat het nog gemakkelijker maakt dan voorheen om applicaties van GtkStatusIcon te porten.

Overig nieuws
Vorige maand ontvingen we zeer gedetailleerde feedback over Warpinator en enkele van de netwerkproblemen die het had in niche (specifieke) situaties. Ik wil alle mensen bedanken die het hebben helpen testen. De tool heeft sindsdien veel stabiliteitsverbeteringen ondergaan.

Nemo heeft aanvullende prestatieverbeteringen ontvangen.

Posted by:

Joan

Leave A Comment

Your email address will not be published. Required fields are marked (required):

Back to Top